CHAPTER 5
NON-PARAMETRIC TESTS
The methods described in chapter 4 are all based on the following assumptions:
1. Simple random sample.
2. The data is numeric.
3. The data is normally distributed.
4. For comparing two population means, it is assumed that the variances of the two
populations underlying each of the samples are equal (Homogeneity of population
variances).
These methods are referred to as parametric methods since their application involves
estimating the parameters (mean, variance etc.) of the underlying distribution.
Many statistical tests require that your data follow a normal distribution. Sometimes this
is not the case. In some instances it is possible to transform the data to achieve
approximate Normality. For example, for a variable measured on an interval scale, taking
the logarithm of the data values may render approximate Normality. In other cases this is
not possible or the sample size might be so small that it is difficult to ascertain whether or
not the data a normally distributed. In such cases it is necessary to use a statistical test
that does not require the data to follow a particular distribution. Such a test is called a
non-parametric or distribution free test.
The methods of chapters 4 are also appropriate for data measured on an interval scale.
However, for data recorded on an ordinal scale, or worse, on a nominal scale, these tests
are inappropriate. For data on an ordinal scale, tests based upon the ranks of the data
have been developed. (Note that many of the distribution-free tests are also rank tests.)
For nominal data, more restrictive (or less powerful) tests are also available, such as the
chi-squared (χ2) test. It is preferable to use a parametric test over a nonparametric test,
since parametric tests are more powerful. However, we should use nonparametric tests
when the sample data do not meet the required assumptions that underlie the parametric
tests.
There are numerous nonparametric tests available, and SPSS includes most of them. Here
in this chapter we will describe some of these tests which serve as non-parametric
counterparts to the Student’s t tests and ANOVA described in Chapter 4 for comparing
two means.
The Nonparametric Tests option of the Analyze menu offers a wide range of nonparametric tests, as illustrated in Figure 5.1 below.

5.1 Sign Test: One Sample (Single set of observations)
The sign test is used to test the null hypothesis that the median of a distribution is equal to
some value. The sign test can be used for testing:
• One-sample T-test
• Paired T-test

•

Ordered categorical data where a numerical scale is inappropriate but where it is
possible to rank the observations.

The binomial test is useful for determining if the proportion of people in one of two
categories is different from a specified amount.
Example 5.1:
If we asked people to select one of two tea types, A or B, we could determine if the
proportion of people who selected a type A is different from.5. (That is, is the proportion
of people who selected a type A different from the proportion of people who selected a
type B.)
SPSS assumes that the variable that specifies the category is numeric. If the variable is
string then we should recode the variable before we can perform the binomial test. You
may use automatically recoding variable technique. Automatically recode is described in
Chapter 1.
As always, we will perform the basic steps in hypothesis testing:
1. State the null and alternative hypotheses: H0: P =.5 versus H1: P ≠.5, where P is
the proportion of people who selected type A.
2. Determine if the hypotheses are one- or two-tailed. These hypotheses are twotailed as the null is written with an equal sign.
3. Specify the α level: α =.05
4. Perform the statistical test.
SPSS Step by Step:
•

Click Analyze ⇒ Nonparametric Tests ⇒ Binomial as shown in Figure 5.1.

Figure 5.1: Non-Parametric Tests
The Binomial dialog box appears.
•
•

Click the variable of interest from the list at the left by clicking on it, and then
move it into the Test Variable List by clicking on the arrow button. In this
example, we select the variable TEA and moved it into the Test Variable List box.
Enter.50 in as a value of Test Proportion box (if it does not already contain it) as
illustrated in Figure 5.2.

Figure 5.2: Binomial Test
•

Click on the OK button to perform the test. The SPSS output viewer
appears with the binomial output as illustrated in Figure 5.3.:

Binomial Test

TEA

Group 1
Group 2
Total

Category
Tea: Type A
Tea: Type B

N
33
17
50

Observed
Prop.
.66
.34
1.00

Test Prop.
.50

Asymp. Sig. (2-tailed)
.033a

a. Based on Z Approximation.

Figure 5.3: Result of Binomial Test
Conclusion:
The output tells us that there are two groups: Type A and Type B. The column labeled N
tells us that there were 33 people who reported that they would prefer a type A and 17
people who reported that they would prefer a type B.
The Observed Prop. column gives the observed proportions (.66 = 33/ (33 + 17). The
next column, Test Prop., gives the value that you entered in the Test Proportion box in
the Binomial Test dialog box. The last column, Asymp. Sig. (2-tailed), gives the p value
for this statistical test. As always, when the p value is less than or equal to your α level,
you can reject H0.
Decide whether to reject H0. The p value in this example is.033 which is less than α level
of.05. Thus, we reject H0 that the mean proportion of people who would prefer a type A
as a Tea is equal to.5.
Note:
For Binomial test, SPSS includes values that are exactly equal to the median — it takes
r+ = the number of observations that are greater than M and
r- = the number of observations that are less than or equal to M. Any ties should
therefore be excluded manually as follows.
Example 5.2:
The Hemoglobin for 15 children are shown below:
13.5, 11.7, 8.9, 8.0, 12.9, 6.7, 7.1, 6.3, 9.4, 8.2, 8.5, 7.5, 8.7, 8.2, 8.1
Test to see if the Hemoglobin equals 8.
•
•

Open the SPSS data file called Hemoglobin
Check the normality for the distributions of Hemoglobin for the 15 children. The
histogram and Shapiro-Wilk tests of Normality are shown in Figure 5.4. It is clear
that the distribution of Hemoglobin is skewed to the right. Significance (P-value)
of Shapiro-Wilk statistic is equal to 0.023 which is smaller than α = 0.05 , then
we reject the null hypothesis that says the Hemoglobin is normally distributed.

This data should be analyzed using the nonparametric techniques. Thus, these
data are more appropriately analyzed using the nonparametric Sign test than the
parametric independent samples.
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Figure 5.4: Histogram and Tests of Normality
SPSS Step by Step:
• Click on Data ⇒ Select Cases ⇒ If condition is satisfied ⇒ click on If
• In the box type in your variable name then ≠ M, where M is the median value
specified in your null hypothesis; in this case M=8
• Click on Continue then OK.
To perform the sign test, follow the following steps:
•
•
•

•

Click on Analyze ⇒ Nonparametric Tests ⇒ Binomial…
Choose the Hemoglobin as the Test Variable
Under Define Dichotomy in the lower left hand corner of the pop-up screen,
choose
Cut Point and specify your null value (i.e. 8.0 in the case of paired data, etc.) as
shown in Figure 5.5.
Click on OK. The output will look like Figure 5.6.

Conclusion:
Since Sig. (P-value) = 0.180, then we reject the null hypothesis. We would conclude that
there is insufficient evidence to conclude that the Hemoglobin is different from 8.0.

Note: This conclusion is the same as we got by using paired samples T-test.

Figure 5.5: Binomial Test Windows

Binomial Test

Hemoglobin

Group 1
Group 2
Total

Category
<= 8
>8

N
4
10
14

Observed
Prop.
.29
.71
1.00

Test Prop.
.50

Exact Sig.
(2-tailed)
.180

Figure 5.6: Result of Binomial Test

5.2

Mann-Whitney Test: Two Independent Samples

The Mann-Whitney test for testing independent samples is a non-parametric test that is
useful for determining if there exist significant differences between two independent
samples. The Mann-Whitney test is the nonparametric version of the two-independent
samples test described in Chapter 4. It is often used when the assumptions of the T-test
have been violated. Thus it is useful if:
•
•
•

The dependent variable is ordinal scaled instead of interval or ratio.
The assumption of normality has been violated in a T-test (especially if the
sample size is small.)
The assumption of homogeneity of population variances has been violated in a Ttest.

As the total number of observations in the two samples increases, the distribution of the
Mann-Whitney U test statistic can be approximated by the Normal distribution.

SPSS assumes that the independent variable is represented numerically. In any sample
data set, we must first convert the independent variable from a string variable to a
numerical
Example 5.3:
Recall the data from AIDS file. In that data set, we have information about AIDS rates
for different world health organization regional office. Suppose we want to test if
Europe's AIDS rate is higher than AIDS rate for Eastern Mediterranean in 1992.
Var.
Description
WHOReg World Health Organization Regional Office
1 = Africa,
2 = Americas,
3 = Eastern Mediterranean
4 = Europe, 5 = South-East Asia, 6 = Western Pacific
Rate92
Cases per 100,000 population, 1992
Before performing the test, let's do the following:
• Open the SPSS data file called AIDS.
• Use Select Cases to choose Eastern Mediterranean and Europe from the
WHOReg. (Select cases is discussed in Chapter 1).
• Check the normality for the distributions of AIDS rates for Eastern Mediterranean
and Europe. The histograms for the two groups are shown in Figure 5.7. It is clear
that the two distributions are skewed to the right and have comparable shape,
which are definitely not normal. These data should be analyzed using the
nonparametric techniques. Thus, these data are more appropriately analyzed using
the nonparametric Mann-Whitney U test than the parametric independent
samples.
Eastern Mediterranean

Europe

40

Count

30

20

10

0.0

25.0

50.0

75.0

Cases per 100,000 population, 1992

100.0

0.0

25.0

50.0

75.0

100.0

Cases per 100,000 population, 1992

Figure 5.7: Histograms for Eastern Mediterranean and Europe.
As always, we will perform the basic steps in hypothesis testing:

We will follow the following steps:
1.
State the null and alternative

hypotheses: H 0 : µ Europe = µ E .Med

versus

H a : µ Europe > µ E .Med
2. Specify the α level. For example choose α =.05.
3. Determine the appropriate statistical test. In this case, AIDS rates is approximately
ratio scaled, and we have multiple (2) groups, so the Mann-Whitney test is appropriate.
4. Use SPSS to perform the Mann-Whitney U test.
SPSS Step by Step:

•
•
•
•
•

Click on Analyze ⇒ Nonparametric Tests ⇒ 2 Independent Samples… The
Two-Independent-Samples Test dialog box will appear.
Click rate92 and transfer it to the Test Variable List.
Click whoreg and transfer it to the box labeled Grouping Variable.
There are several types of tests to choose from in the dialog box but we will agree
with the default test, the Mann-Whitney U.
You need to tell SPSS how to define the two groups. Click on the <Define
Groups> button. The Define Groups dialog box appears. In the window
displayed, (shown in Figure 5.8), enter values 3 and 4 for Groups 1 and 2
respectively. We will call the Eastern Mediterranean Group 1 (they are coded 3 in
the data file) and we will call the Europe Group 2 (they are coded 4).

Figure 5.8: Defining Groups for Mann-Whiteny Test

•

Click on <Continue> button to close the Define Groups dialog box.

The Independent Samples Mann-Whitney test window should now look like Figure 5.9.

Figure 5.9: Two-Independent Samples Test Window

•

Click on <OK> button in the two-Independent-Samples Tests dialog box to
perform the Mann-Whitney test. The results have two main parts: Ranks statistics
and inferential statistics.

Conclusion:
The first part of the output gives the means and sums of ranks within each group, (shown
in Figure 5.10).
Ranks
Cases per 100,000
population, 1992

WHO Region
Eastern Mediterranean
Europe
Total

N
22
48
70

Mean Rank
28.36
38.77

Sum of Ranks
624.00
1861.00

Figure 5.10: Summary Statistics for Ranks

This part gives some summary information about the two groups. In this example, there
are 22 countries in the Eastern Mediterranean, with mean rank of 28.36. There are 48
countries in Europe (N), with mean rank of 38.77. The last column gives the sum of ranks
for each of the two groups.
The second part of the output gives the result of Mann-Whitney test, (shown in Figure
5.11).

Test Statisticsa

Mann-Whitney U
Wilcoxon W
Z
Asymp. Sig. (2-tailed)

Cases per 100,000
population, 1992
371.000
624.000
-2.038
.042

a. Grouping Variable: WHO Region

Figure 5.11: Result of Mann-Whitney Test

The Mann-Whitney U statistic is equal to 371.00 with significance (P-value) equal to
0.042. Thus, we conclude that there is a significant difference in the mean AIDS rate
between Eastern Mediterranean and Europe. One would conclude that Europe AIDS rate
is significantly higher than Eastern Mediterranean since the mean ranks are 28.36 and
38.77 for Eastern Mediterranean and Europe, respectively.
Example 5.4:
The data in Table 5.1 represent the biceps skinfold thickness (mm) in two groups of
patients.
We are interested to test if there exists significant difference between the two groups.
Crohn’s Disease
1.8 2.8 4.2 6.2
2.2 3.2 4.4 6.6
2.4 3.6 4.8 7.0
2.5 3.8 5.6 10.0
2.8 4.0 6.0 10.4

Coeliac Disease
1.8 3.8
2.0 4.2
2.0 5.4
2.0 7.6
3.0

Table 5.1: Biceps skinfold thickness data

SPSS Step by Step:
• Open the SPSS data file called skinfold. Note that the variable Group indicates
the disease group to which the patient belongs.
• Check the normality for the distributions of biceps skinfold thickness (mm) in two
groups of patients. The histograms for the two groups are shown in Figure 5.12.
It is clear that the two distributions are skewed to the right and have comparable
shape. Thus, these data are more appropriately analyzed using the nonparametric
Mann-Whitney U test than the parametric independent samples.
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Figure 5.12: Histograms for the two groups (Crohn’s and Coeliac Diseases)
Carry out a Mann-Whitney test as we described in Example 5.3.
Conclusion:
The first part, (shown in Figure 5.13), gives some summary information about the two
groups. In this example, there are 20 patients in Crohn's disease, with mean rank of
16.53. There are 9 patients in Coeliac disease group, with mean rank of 11.61. The last
column gives the sum of ranks for each of the two groups.
Ranks
Biceps skinfold thickness

Disease Group
Crohn's Disease
Coeliac Disease
Total

N

Mean Rank
16.53
11.61

20
9
29

Sum of Ranks
330.50
104.50

Figure 5.13: Summary Statistics for Ranks

The second part of the output gives the result of Mann-Whitney test, (shown in Figure
5.14). The Mann-Whitney U statistic is equal to 59.50 with significance (P-value) equal
to 0.153. Thus, we conclude that there is insignificant difference between the two
patient's groups.
Test Statistics b

Mann-Whitney U
Wilcoxon W
Z
Asymp. Sig. (2-tailed)
Exact Sig.
[2*(1-tailed Sig.)]

Biceps skinfold
thickness
59.500
104.500
-1.439
.150
.153

a. Not corrected for ties.
b. Grouping Variable: Disease Group

a

Figure 5.14: Result of Mann-Whitney Test

5.3 Sign Test: Two Related Samples (Paired Data)
The Sign test for testing related samples is a non-parametric test that is useful for
determining if the paired mean difference is different from each other. The Sign test is the
nonparametric version of the paired samples t test. It is often used when the assumptions
of the paired samples T-test have been violated. We use this test if we have repeated
measures of one sample and the population is not normally distributed. This test can be
used with ordinal and numerical data.
Example 5.5:
The data in Table 5.2 shows the hours of relief provided by two analgesic drugs in 12
patients suffering from arthritis. Is there any evidence that one drug provides longer relief
than the other?
Case Drug A Drug B
1
2.00
3.50
2
3.60
5.70
3
2.60
2.90
4
2.60
2.40
5
7.30
9.90
6
3.40
3.30
7 14.90
16.70
8
6.60
6.00
9
2.30
3.80
10
2.00
4.00
11
6.80
9.10
12
8.50
20.90
Table 5.2: Drug's Data
SPSS Step by Step:
• Analyze ⇒ Nonparametric Tests ⇒ 2 Related Samples…
• Click Drug_A and Drug_B then click on the arrow to transfer them under Test
Pair(s) List:
• Under Test Type select Sign as shown in Figure 5.15.
• Click on OK. The output will look like Figure 5.16.

Figure 5.15: Two-Related-Samples Tests: Sign Test
Frequencies
N
Drug_B - Drug_A

Negative Differencesa
Positive Differencesb
Tiesc
Total

3
9
0
12

a. Drug_B < Drug_A
b. Drug_B > Drug_A
c. Drug_B = Drug_A
Test Statisticsb

Exact Sig. (2-tailed)

Drug_B Drug_A
.146a

a. Binomial distribution used.
b. Sign Test

Figure 5.16: Result of Sign Test
Conclusion:

The first part of the output summarized the results. Negative differences refer to the
subjects whose Drug_B was less than Drug_A. Positive differences refer to the subjects
whose Drug_B was higher than Drug_A. In this case there was no subject whose Drug_A
was the same as Drug_B. The significance (P-value) = 0.146, then we do not reject the
null hypothesis. We would conclude that there is no evidence for a difference between
the two treatments.
Note:
• Note: If P-value is smaller then 0.05 then we reject the null hypothesis in favor of
the alternative hypothesis. In this case one may use the mean rank for positive and
negative ranks to know which one is higher.

•
•

If you were carrying out a one-sided test, you would need to divide the p-value by
2.
(Note that the Wilcoxon Signed Rank Sum Test (Will be discussed later) is also
appropriate in these situations and is a more powerful test than the sign test
because it takes account of the magnitude of the differences as well as the sign.)

5.4 Wilcoxon Signed Ranks Test: Two Related Samples
The Wilcoxon signed ranks test is the nonparametric version of the paired samples t test.
It is often used when the assumptions of the paired samples T-test have been violated. We
use this test if we have repeated measures of one sample and the population is not
normally distributed. This test can be used with ordinal and numerical data.
This test takes into account information about the magnitude of differences within pairs
and gives more weight to pairs that show large differences than to pairs that show small
differences. The test statistic is based on the ranks of the absolute values of the
differences between the two variables.
Example 5.6:
For purposes of an example, we will perform a Wilcoxon signed ranks test on change in
the average rate data form the AIDS data. Specifically, we are interested to see if there
was any significant change in the average rate of AIDS cases from 1992 to 1993.
SPSS Step by Step:
• Open the SPSS data file called AIDS
• Analyze ⇒ Nonparametric Tests ⇒ 2 Related Samples…
• Click rate92 and rate93 then click on the arrow to transfer them under Test
Pair(s) List:
• Under Test Type select Wilcoxon as shown in Figure 5.17.
• Click on OK. The output will look like Figure 5.18.

Figure 5.17: Two-Related-Samples Tests: Wilcoxon Test
Ranks
N
Cases per 100,000
population, 1993 Cases per 100,000
population, 1992

56a
89b
62c
207

Negative Ranks
Positive Ranks
Ties
Total

Mean Rank
79.33
69.02

Sum of Ranks
4442.50
6142.50

a. Cases per 100,000 population, 1993 < Cases per 100,000 population, 1992
b. Cases per 100,000 population, 1993 > Cases per 100,000 population, 1992
c. Cases per 100,000 population, 1993 = Cases per 100,000 population, 1992

Test Statisticsb

Z
Asymp. Sig. (2-tailed)

Cases per 100,000 population, 1993 Cases per 100,000 population, 1992
-1.678a
.093

a. Based on negative ranks.
b. Wilcoxon Signed Ranks Test

Figure 5.18: Result of Wilcoxon Test
Conclusion:
The first part of the output summarized the results. Negative ranks refer to the subjects
whose
average rate of AIDS cases from 1993 were less than average rate of AIDS cases from
1992. Positive ranks are those subjects whose average rate of AIDS cases from 1993 was
higher than average rate of AIDS cases from 1992. In this case there were subjects whose
average rate of AIDS cases were the same for 1992 and 1993. Notice the mean rank for
the Negative ranks and Positive ranks are 79.33 and 69.02, respectively. The Wilcoxon
signed ranks statistics, converted to a z-score, is equal to -1.678 with a significance (Pvalue) equal to 0.093. Thus there is insufficient evidence to conclude the average rate of
AIDS cases changes significantly from 1992 to 1993 at the 5% significance level.
Example 5.7:
The data in Table 5.3 represent the numbers of attacks of angina experienced by patients
in a drug trial. The data are taken from Bland (2000).
Placebo

Pronethalol

2
17
3
7
8
14
23
34
79
60
323
71

0
15
0
2
1
7
16
25
65
41
348
29

Table 5.3: Angina Drug Trial data
SPSS Step by Step:
• Open the SPSS data file called angina.
• Check the normality for the distributions of the numbers of attacks of angina
experienced by patients in a drug trial. The histograms for the two groups are
shown in Figure 5.19. Histograms for Placebo and Pronethalol data indicate very
strong departure from Normality in these measurements for each of the treatment
groups.
Thus, these data are more appropriately analyzed using the
nonparametric Wilcoxon test than the parametric related samples.
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Figure 5.19: Histograms for the Placebo and Pronethalol data
Carry out a Wilcoxon test as we described in Example 5.6.
Conclusion:
The output shown in Figure 5.20. Negative ranks refer to patients whose number of
attacks of angina using Pronethalol drug trial was smaller than Placebo drug trial.
Positive ranks refer to patients whose number of attacks of angina using Pronethalol drug
trial greater greater than Placebo drug trial. In this case there were not patients whose
number of attacks of angina using Pronethalol were the same for Placebo drug trial.
Notice the mean rank for the Negative ranks and Positive ranks are 6.09 and 11.00,
respectively.
Ranks
N
Pronethalol - Placebo

Negative Ranks
Positive Ranks
Ties
Total

a. Pronethalol < Placebo
b. Pronethalol > Placebo
c. Pronethalol = Placebo

11a
1b
0c
12

Mean Rank
6.09
11.00

Sum of Ranks
67.00
11.00

Test Statisticsb

Z
Asymp. Sig. (2-tailed)

Pronethalol
- Placebo
-2.201a
.028

a. Based on positive ranks.
b. Wilcoxon Signed Ranks Test

Figure 5.20: Result of Wilcoxon Test

The Wilcoxon signed ranks statistics, converted to a z-score, is equal to -2.201 with a
significance (P-value) equal to 0.028. Thus there is sufficient evidence to conclude that a
difference has been detected between the means of the two treatment groups at the 5%
significance level.

5.5 Kruskal-Wallis H Test: Three or More Independent
Samples
The Kruskal Wallis H test is used when you have one independent variable with two or
more levels and an ordinal dependent variable. In other words, it is the non-parametric
version of one-factor independent measures ANOVA described in Chapter 4 and a
generalized form of the Mann-Whitney test method since it permits two or more groups.
We use Kruskal-Wallis test when the independent samples come from populations with
the same shape, although not necessarily normal. The Kruskal Wallis H test can be used
with ordinal, interval, or ratio data. It is often used when the assumptions of the onefactor independent measures ANOVA have been violated. Thus it is useful if:
•
•
•

The dependent variable is ordinal scaled instead of interval or ratio.
The assumption of normality has been violated in ANOVA (especially if the
sample size is small.)
The assumption of homogeneity of population variances has been violated in
ANOVA test.

The null hypothesis states that there are no significant differences among the levels of the
independent variable.
Example 5.8:

Recall the data from AIDS file. In that data set, we have information about AIDS rates
for different world health organization regional office. Did all six WHO regions
experience roughly the same AIDS rate of cases in 1993?

Var.
Description
WHOReg World Health Organization Regional Office
1 = Africa, 2 = America,
3 = Eastern Mediterranean
4 = Europe, 5 = South-East Asia, 6 = Western Pacific
Rate93
Cases per 100,000 population, 1993
SPSS Step by Step:
• Open the AIDS data file
• Check the assumption of normality. The histograms for the six regions are shown
in Figure 5.21. It is clear that the six histograms not normal in shape, they are
skewed to the right and have comparable shape. Thus, these data are more
appropriately analyzed using the nonparametric Kruskal-Wallis H test than the
one-factor independent measures ANOVA.
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Figure 5.21: Histograms for the Six WHO Regions
SPSS Step by Step:

•
•
•
•
•

Open the SPSS data file called AIDS.
Click on Analyze ⇒ Nonparametric Tests ⇒ K Independent Samples… The
Tests for Several Independent Samples dialog box will appear.
Click rate93 and transfer it to the Test Variable List.
Click whoreg and transfer it to the box labeled Grouping Variable.
There are several types of tests to choose from in the dialog box but we will agree
with the default test, the Kruskal-Wallis H test.

•

You need to tell SPSS how to define the two groups. Click on the <Define
Range> button. The Define Range dialog box appears. In our data file, the six
groups are labeled from 1 to 6. In the window displayed, (shown in Figure 5.22),
enter values 1 and 6 for Groups Minimum and Maximum respectively.

Figure 5.22: Defining Groups for Kruskal-Wallis H Test

•

Click on <Continue> button to close the Define Groups dialog box.

The Tests for Several Independent Samples dialog box will now look like Figure 5.23.

Figure 5.23: Test for Several Independent Samples Test Window

•

Click on <OK> button in the dialog box to perform the Kruskal-Wallis H test.
The results have two main parts: Ranks statistics and inferential statistics.

Conclusion:

The first part, (shown in Figure 5.24), gives some summary information about the six
groups. In this example, there are 46 countries in Africa, with mean rank of 138.82, 45
countries in Americas with mean rank of 142.32,…, and 35 countries in Western Pacific
with mean rank of 64.76. These ranking appear quite different but we still have to rely on
the statistical test to determine whether this sense is correct.

Ranks
Cases per 100,000
population, 1993

WHO Region
Africa
Americas
Eastern Mediterranean
Europe
South-East Asia
Western Pacific
Total

N
46
45
22
48
11
35
207

Mean Rank
138.82
142.31
71.50
89.67
54.09
64.76

Figure 5.24: Summary Statistics for Mean Ranks

The second part, (shown in Figure 5.25) of the output gives the result of Kruskal-Wallis
H test. Kruskal-Wallis H statistic (Chi-Square) is equal to 67.252 with significance (Pvalue) equal to 0.000. Thus, we conclude that AIDS rate is statistically significantly
different between the six WHO regions.
Test Statisticsa,b

Chi-Square
df
Asymp. Sig.

Cases per 100,000
population, 1993
67.252
5
.000

a. Kruskal Wallis Test
b. Grouping Variable: WHO Region

Figure 5.25: Result of Kruskal-Wallis H Test

5.6 The Friedman Test: Three or More Dependent Samples
The Friedman test is used when you have one independent variable with three or more
levels and an ordinal dependent variable. In other words, it is the non-parametric version
of one-factor repeated measures ANOVA described in Chapter 4. We use Friedman test
when the independent samples come from populations with the same shape, although not
necessarily normal. The Friedman test can be used with ordinal, interval, or ratio data. It
is often used when the assumptions of the one-factor repeated measures ANOVA have
been violated.
Example 5.9:

Recall the SPSS data file Blood_pressure. Does systolic blood pressure change
significantly during the three tasks examined in this study? The three tasks were: at rest
[sbprest], performing mental arithmetic [sbpma], and immersing a hand in ice water
[sbpcp].
SPSS Step by Step:

•

Open the SPSS data file called Blood_pressure.

•
•
•

Click on Analyze ⇒ Nonparametric Tests ⇒ K dependent Samples… The
Tests for Several Related Samples dialog box will appear.
Click [sbprest], [sbpma], and [sbpcp] and transfer them to Test Variable(s).
There are several types of tests to choose from in the dialog box but we will agree
with the default test, the Friedman test. The Tests for Several Related Samples
dialog box will now look like Figure 5.26.

Figure 5.26: Tests for Several Related Samples

•

Click on <OK> button in the dialog box to perform the Friedman test. The results
have two main parts: Ranks statistics and inferential statistics.

Conclusion:
The first part, (shown in Figure 5.27), gives the mean ranks during the three tasks
examined in this study. The mean ranks for the systolic blood pressure during immersing
a hand in ice water, performing a mental arithmetic, and at rest are equal to 2.51, 2.28,
and 1.21, respectively. These ranking appear quite different but we still have to rely on
the statistical test to determine whether this sense is correct.
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Figure 5.27: Summary Statistics for Mean Ranks

The second part, (shown in Figure 5.28) of the output gives the result of Friedman test.
Friedman statistic (Chi-Square) is equal to 170.411 with significance (P-value) equal to
0.000. Thus, we conclude that the systolic blood pressure changes significantly during the
several physical and mental stressor tasks.
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Figure 5.28: Result of Friedman Test

